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Civil Site Design and HECRAS 2D Flood Modelling 
HECRAS version 5 and later includes functionality to analyse water 

flows moving across a surface.  this is known as 2D flood modelling 

and provides more accurate modelling of water movement across a 

surface than 1d (or section based) flood modelling. 

If you are using Civil Site Design, you now have functionality to work 

with HECRAS input and output files via the Export HECRAS 2D and 

Import HECRAS 2D commands. 

For this example, we’ll use HECRAS to undertake a 2D flow analysis of 

an existing creek abutting an existing car park being considered for 

expansion.  The existing creek flow performance is to be maintained 

following the new works, and enhancement of the creek flow may be 

required if flooding is occurring downstream. 

A peak flow of 10m3/s must be managed in the creek. 

The Tutorial Data Set 
The tutorial data is installed with the software installation to the following location 

(Note: the HEC-RAS menu must be ticked on for inclusion during install): 

Civil 3D: C:\CSS Training Data\Civil Site Design\HEC-RAS\HECRAS 2D Tutorial – Start.dwg 

CAD: C:\CSS Training Data\Civil Site Design\HEC-RAS\HECRAS 2D Tutorial – Start - CAD.dwg 

This drawing file includes a surface and is located in the MGA-55 Coordinate system. 

At this stage, there is no surface associated with the data set.  This can be remedied 

using Model Viewer.  To do this: 

• Start the ribbon command Roads Tab > Select Panel > 

Model Viewer.  This will start Model Viewer and populate 

the existing surface name into the Toggle Display form 

• Under Base Surface, click on the picklist dropdown for 

Style and select Image from Satellite (Aerial Photo) 

•   The Satellite Setup form 

will display.  Firstly click on 

the … button, select 

Australia MGA-55.prj from 

the list and click OK. 

•   Click on Confirm Satellite 

Data to see the imagery available under the surface location. 

•   Roll the mouse to zoom out but 3 steps only (the more zoom out, the 

less quality) and click the Accept button top left. 

•   Click OK to exit the Toggle Display form.  An image is associated with the 

surface in Model Viewer.   
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For AutoCAD and Civil 3D users, an image is also inserted in the drawing.   

For BricsCAD users, an image is saved to the –Data folder.  When inserted into the drawing it will automatically 

position itself correctly. 

 

Exporting Terrain Data to HECRAS 
The Export HECRAS 2D command will take the combination of your design and existing surfaces and share them 

across to HECRAS as a single geotiff file.  The goetiff describes the surface extents and elevations for HECRAS.  The 

command can be run directly from the ribbon interface, or can be run from inside Model Viewer. 

If you opt to run the command from the CAD ribbon interface, the Toggle Display form will display for you to 

confirm what surface data to bring across to HECRAS - you can opt to just include the existing surface conditions, 

or you could send across a combined surface containing the existing surface as well as your design surfaces.  This 

would enable you to analyse pre and post development conditions.  If you run the command from inside Model 

Viewer, you get the benefit of directly reviewing the surface before export across to HECRAS. 

In the Export HECRAS 2D command you need to specify a location and name for the geotiff you are exporting, as 

well as a grid spacing.  Set a grid spacing that matches the accuracy of the data you have, to ensure you don't lose 

information and, conversely, you don't include unnecessary data. 

Once you have a geotiff file you can use this to generate terrain data in HECRAS. 

Steps: 

1. If you closed Model Viewer, click on the ribbon command Roads Tab > Select Panel > Model Viewer.  This 

will start Model Viewer. 
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2. If required, confirm the settings via Toggle Display.  If the previous steps are complete, the surface and 

image required to be analysed in HECRAS should already by shown.  

 
Note: in the above image the exaggeration has been set to 5 to accentuate the shape of the terrain.  

Exaggeration must be set to 1 before exporting 

3. Click on the Analyse Tab > HECRAS 2D Panel >  Export button 

 
In the Export form you confirm the location, name and grid size of the file to export.   

4. Leave the Grid Spacing to the default of 1  

5. Note the path to the output HECRAS file, then click Export to create a HECRAS input file. 
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Import and Analysis in HECRAS 
After starting your HECRAS project and establishing the units and setup, you need to open RAS Mapper and 

create a terrain.  You will firstly set up a projection, or coordinate system, for your data.   

HECRAS Project Setup 

 

6. Click on File > New.  Select a location and name for the new project. 

 

7. Click on Options > Unit System to confirm the units (this example is using Metric units). 

HECRAS RAS Mapper  

8. From the HEC-RAS interface, select GIS Tools > RAS Mapper… or else click on the RAS Mapper  

button. 

The RAS Mapper form will display with a menu at the top and a list of layers along the side.  The first task is to 

populate the Terrain layer using the .tif created by Civil Site Design.  Optionally, a Map Layer can be included for 

the aerial photo. 

Assigning a Projection 

Before creating a terrain, a projection must be set.  This is controlled by a projection file, extensIon .prj.  Some 

typical Australian and other country specific .prj files are contained in the Civil Site Design Settings folder, in the 

Visualisation and then Projections folders.  There is also a website where you can generate .prj files by typing in 

your location. 

9. From the Ras Mapper form, click on Tools > Set Projection for Project. 

For this example, a .prj has been provided in the same directory as the tutorial drawing: C:\CSS Training Data\Civil 

Site Design\HEC-RAS 

10. Navigate to the above folder location and open 

Australia MGA-55.prj.  This assigns the Projection. 

 

After selecting the .prj file click OK to apply the 

projection.   
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Adding a Terrain 

When you open the Terrain form and create a new Terrain, you will have an opportunity to load a terrain file - 

here you can use the exported file from Civil Site Design to generate the terrain data for HECRAS. 

11. Click on Tools > New Terrain 

 

12. Click on + to add a new data source for the terrain.  Navigate to the output location of the .tif and open 

that file  

This data will be used to create a Terrain – in HECRAS the terrain is saved as a file with extension .hdf. 

 

13. Click on Create to import the Terrain. 

14. Note under the Terrains layer is a new layer.  Make sure that Terrains is ticked on, then right click on 

Terrain and choose Zoom to Extents to see the full extents of the terrain model in RAS Mapper. 
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Adding an Aerial Photo 

With RAS Mapper you can also include imagery and other geospatial data.  

 

15. Right click on Map Layers and follow the Map Data Layers flyout to select Add Existing Layer. 

When prompted to select a file, use the file type dropdown at the bottom right to select Other (*.*).  

Selecting a .jpg file will then insert it into HECRAS so long as it is accompanied by a world file (.jgw file 

contains the spatial location for a .jpg file).   

16. Select the image file output during step 5 above or C:\CSS Training Data\Civil Site Design\HEC-

RAS\VisSatellite.jpg 

Tick on the image to display it in RAS Mapper.  Right click on the image name to edit the Image Display 

Properties – a transparency can be assigned here. 
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After importing data into RAS Mapper, it will become available in the HECRAS Geometry Editor.  In here you can 

assign flood data along the boundaries, establish the model grid size for flood analysis, edit the surface breaklines, 

assign different surface Manning's n values and more. 

Close RAS Mapper. 

Creating the 2D Flow Area 

17. From the HEC-RAS interface, click on View/Edit Geometric Data  

A new form will display entitled Geometric Data.  The surface will initially display with the colours representing 

elevations.  To show the aerial photo, click on  and tick on to display the Map Layer you added. 
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The linework in your original drawing can be included in the Geometric data as a layer, after exporting it out from 

the drawing in an appropriate format for HECRAS. 

Now to create a 2D flow area for analysis.  To keep it simple, select the extents of the terrain as the boundary.  

This is a relatively well defined basin, so the extents of the boundary are typically much higher than the creek 

(excepting the inflow and outflow locations north and south).  When you select the area you can establish a 

calculation mesh across the surface.  In our example, a 10m mesh is suitable and matches with the existing 

surface triangulation. 

18. Click on the 2D Flow Area  button.  Use the left mouse button to sketch the boundaries of a flow 

area.  Double click on the start of the first line drawn to close the area. 

19. At the prompt, name the area Total Flow 

Area and click OK.  
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20. Left click on the new area and select Edit 2D Flow Area … 

In the 2D Flow Areas form you apply a computational mesh across the surface, as well as establish Manning’s n 

values to apply for the default area and for any other Land Cover areas added. 

 

21. Click on Generate Computation Points on Regular Interval with All Breaklines… 

22. Set DX and DY both to 10 and click Generate Points in 2D Flow Area 

 

23. Click OK to close the 2D Flow Areas form. 

The pattern on the 2D flow area in the Geometric Editor will change – zooming in will expose the 

individual mesh areas.  Zoom in to view the mesh shape.  If any are red in colour then you will need to use 

the Edit > Add Points command to add more mesh point or else adjust the boundary shape. 

 

Note: if it is required to edit the outline of the 2D flow area, use the menu command Edit > Move Points/Objects or 

other edit tool in the Edits menu. 
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The 2D Area Breaklines  command can be used to incorporate breaklines into the flow area to better 

represent ridge and valley lines for the surface. 

Setting Boundary Conditions (for Incoming and Outgoing flows) 

Flow comes from the ponding areas along the southern boundary of the surface, so a boundary condition needs 

to be set along this edge.  We can then assign inflow along this boundary to spill across the surface.  The low side 

of the surface is along the northern boundary, so we can set a boundary condition along there for how water can 

exit along that boundary. 

24. Click on the SA/2D Area BC Lines button  

25. Click inside the 2D Flow Area along the southern boundary to set an incoming flow line.  Flow will come in 

uniformly along this line.  Double click to finish the boundary  

 
 

26. Name the boundary Inflow and click OK to create. 

27. Repeat the above 3 steps to create an ‘outflow’ boundary.  Run the boundary just outside the 2D Flow 

Area along the west, north and eastern boundary where the properties are and name the flow area 

boundary Outflow.  The outputs should look similar to below: 
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Note that in the geometry editor you can incorporate both 1D and 2D flow zones into a single model for analysis. 

Additionally, boundary conditions can be set within the 2D area to represent different hydraulic behaviours.  After 

setting up the surface and boundary conditions, you can move onto assigning the flow conditions.   

28. Click on File > Save Geometry Data.   

29. Name the file Existing Conditions and click OK 

Note: Where a boundary is not specified, water is assumed to well up along the boundary as if the boundary edge 

was a wall. 

Establish Flow Conditions along the Boundaries 

In the Flow Conditions form, we can set an inflow for the Inflow incoming boundary along the southern boundary.  

In this example, we're working with a peak flow of 10 m3/s and describing the storm shape as a simple bell type 

curve.  You can copy and paste from spreadsheet input tools, such as Excel, to quickly create the flow information 

for HEC-RAS.  For the outgoing boundary conditions, we set for a normal depth and apply a friction slope to 

describe how the exiting flow is handled. 

30. From the HECRAS menu click on View/Edit Unsteady Flow data  

A new form will display entitled Unsteady Flow Data.  The form will list the 

two Boundary Conditions set for the 2D area. 

 

31. Under Add Boundary Condition Location, click on Add SA/2D Flow 

Area… to include the Total Flow area  

 
32. Click on the -> arrow to include the Total Flow Area for analysis and click OK. 

 

Next, we set the outflow conditions along the northern boundary line we’ve created. 

33. Under Storage/2D Flow Area, click the flow area entitled Outflow 

34. Click on Normal Depth at the top to establish the outflow conditions along this line 

35. Type in a Friction Slope of 0.1 and click OK 

 
The Boundary Condition for the Inflow will be set to Normal Depth. 
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Now we need to assign incoming flows into the system. 

36. Under Storage/2D Flow Area, click on the flow entitled Inflow 

37. Click on Flow Hydrograph to assign a time dependent flow to this 

inflow line 

For Data Time Interval, set the value to 1 hr using the pick list 

To add flows you can type in a Flow for each time step (0 to 48hrs) 

and set for a build up to a peak flow of 10m3/s, however it is often 

quicker to spreadsheet out the required flow characteristics, copy 

them from Excel, and use the paste command to paste them into the 

Flow column. 

 

 

For this purpose, you may wish to open the file Storm Input Calculator.xls file located in the same directory as 

the source drawing.  In this file, you can type in the Minimum and Maximum flow values at the top of the 

form and it will populate values for 1hr increments. 

Set the Maximum Flow to 10m3/s (or higher if you wish).  Then highlight the values in the Flow column and 

copy to clipboard (Ctrl + C or right click and select Copy).  In the Flow Hydrograph form, highlight all Flow cells 

from 0:00 to 48:00 and press Ctrl+V 

 

38. For EG Slope for distributing flow along BC Line, type in 0.1 

 
39. Click OK to assign the flow conditions to the boundaries specified 

40. Click on File > Save Unsteady Flow Data.  Name the file Flows and 

click OK 

41. Click on File > Exit to close the flow data form. 
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Re-establish the Area Conditions 

You may receive an error if you move directly to analysing the flows, without first returning to the Geometric Data 

Editor form and re-establishing the grid calculations to ensure they are correctly saved following the flow 

assignment.  To do this: 

42. From the HEC-RAS interface, click on View/Edit Geometric Data  

43. Click on the 2D area and select Edit 2D Flow Area… 

44. In the form that displays click on Generate Computation Points on Regular Interval with All Breaklines… 

45. Accept the default spacings you previously applied and click Generate Points in 2D Area.  Accept the 

warning message and click Yes. 

46. Click OK to close this form then click on File > Save Geometry Data 

47. Close the Geometry Editor form. 

Analyse the Flows 

When you analyse the system you set up time stamps for calculating flows, reporting times and total analysis 

duration.  RAS Mapper is then used to review the flood extents over time, assess the peak extents, flow depths 

and flow velocities.  As part of this analysis process, HECRAS has created a file to store this storm flow 

information.  Civil Site Design can import this file and visualise it in 3D in Model Viewer. 

The Computation Interval is very important – if it is too large or too small you will generate instability in your 

model or miss important calculation outcomes.  Because we are on a steep site with fast flow in sections, a small 

Computation Interval is required – we’ll be going for 3 seconds. 

48. From the HECRAS menu click on Perform and Unsteady Flow Simulation  button. 

49. Fill out the form as follows: 

a. Tick ON 

i. Geometry Preprocessor 

ii. Unsteady Flow Simulation 

iii. Post Processor 

b. Set the Simulation Time Window 

i. Pick a Starting Date (default selection shown) and Ending Date (same as starting) 

ii. Set the starting time to 0:00 

iii. Set the ending time to 24:00 (for 48hrs of flow calculation time, you would also change 

the Ending Date to be one day past the Starting Date) 
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c. Set the Computational Settings 

i. Set the Computation Interval (how often it calculates levels) to 10 seconds 

ii. Set the Hydrograph Output Interval to 30 minutes 

iii. Set the Mapping Output Interval (time increments displayed in RAS Mapper) to 30 

minutes 

iv. Set the Detailed Output Interval to 30 minutes 

50. Click on Compute 

 
If you receive any information in red text, it is likely that some data has not been saved, data hasn’t been 

fully added or there is an error in the mesh or data input.   

Review the above steps, ensuring you (again) Save Geometry Data and Save Unsteady Flow Data, and try 

computing again. 

 

You’ll have to wait a little while as it processes – 4-6 minutes for a 24 hr calculation period. 

 

51. Close the computations form 

52. Click on File > Save Plan to save the applied flow analysis inputs 

53. Click Close 

You can view the results directly inside HECRAS via RAS Mapper.  As well, you can generate lines for the flood 

extents and other flow outcomes and export this to a geospatial file format suitable for import using the Map 3D 

tools in Civil 3D. 

To check out the results in RAS Mapper, do the following: 
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From the HECRAS interface, click on the RAS Mapper  button. 

 

 Tick on the Depth layer to show the depth of water.  Click on the Depth (Max) text to make it the Selected layer 

and use the slider at the top to change the flow time to see development of flow over time. The play button will 

animate the flow. 

3D Review and Analysis using Model Viewer 

The Import HECRAS 2D command lets you import the HECRAS output file (which is a file with extension 

p##.hdf).  After running the command and selecting the file, a new form displays with the calculated time stamps 

included.   

54. Open Model Viewer 

55. Click on Analyse >  Import HEC-RAS 

56. Click on the ... button to select an output file.  Output files have the name of the HECRAS project file with 

.p##.hdf, where ## is a 2 digit number.  Locate the project folder you saved the HEC-RAS analysis to and 

you will find the output .hdf file/s there.  Select and Open.  
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57. Select a time stamp and see the extents of flooding at that time.   

You can click the play/pause button to   

see the development of flooding over time and 

assess, in 3D, how the flooding may impact 

downstream properties and infrastructure. 
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Video Output 

From the Outputs tab, click on  Record Video to create an animated video file (.avi) of the water. 

 

  



  HEC-RAS 2D Flood Modelling Tutorial 

19 
 

Adding the Flood Extents Linework into your Drawing 
You will need to create an export file from HEC-RAS in order to import it into your drawing as linework. 

Since HEC-RAS interfaces with geospatial systems, you will be generating a geospatial file (ESRI .shp) describing 

the linework.  This needs to then be imported into your drawing. 

Civil 3D and Map 3D include tools to read .shp files and create objects in the drawing from the file/s.  AutoCAD 

and BricsCAD do not natively have functionality to interface with geospatial files such as .shp.  There are third 

party applications, such as Spatial Manager, that deliver functionality to import, export and interrogate geospatial 

data.    

Output from HEC-RAS 

To generate the .shp file of the water extents you need to: 

1. Open HEC-RAS and go into RAS Mapper.  You should see all the results in RAS mapper from your analysis. 

 
2. In the Selected Layer list, right click on the Results Layer (Plan 01) and select Add new results map layer… 

The following form will display: 

3. You can create a new layer displaying any of the Map Type information, at any particular time.  To 

generate the maximum inundation 

a. Select the Map type Inundation Boundary 

b. Under Unsteady Profile, click on Maximum 

c. Confirm to create a Polygon Boundary 

d. Click on Add Map 

e. Right click on the new layer and select Compute/Update 

Stored Map. 

The new layer shows the inundation extents 
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4. Right click on the new layer and select Export Layer > Save Feature to Shapefile (or KMZ if viewing in 

Google Earth)  

 

5. Save the file and then it can be imported into your drawing. 

Import into the Drawing 

There are different options for importing the .shp file into the drawing, depending on the CAD platform. 

AutoCAD/BricsCAD users 

If using AutoCAD or BricsCAD you have some options to include the output .shp file in the drawing: 

1. Obtain Spatial Manager.  After installation, additional geospatial tools are added to the ribbon to enable 

reading and writing ESRI .shp files (as well as numerous other formats) directly in the drawing 

2. Download and install QGIS.  This is a free standalone geospatial application allowing users to add a layer 

of data using the .shp file and saving that data out to a .dxf format (which can be opened in 

AutoCAD/BricsCAD) 

Civil 3D/Map 3D Users 

If using Civil 3D (or AutoCAD Map 3D), the command MAPIMPORT can be used to include the linework from the 

file.   

Note for Civil 3D/Map 3D users: If not already set, you may 

wish to specify the Coordinate System of the drawing by 

either clicking the button or typing MAPCSASSIGN in the Civil 

3d command line.  Use the Search function and then click the 

Assign button.  For this example, we are using MGA-55.  
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After importing the layer, polylines (or hatching) will be included in the drawing: 

 

 


